PeterConnects Receptionist login fails

Incident Report for Evolve IP EU

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 13:50 CEST

Monitoring

We have been informed that the login issue should now be resolved. Could you please test this and confirm via your ticket in the Self Service Portal that the issue has been resolved?
Posted Apr 15, 2026 - 13:01 CEST

Investigating

We are aware of an issue impacting the PeterConnects Receptionist application. Users attempting to sign in get an error message saying: PCAUTH0001: An unknown error occurred.

We are currently investigating with the highest priority and will provide further updates in due course.

If you experience this issue, please raise a case via our Selfservice portal: https://selfservice.xtium.eu
Posted Apr 15, 2026 - 12:41 CEST
This incident affected: Online Business Telephony (OBT - Peter Connects).