Webex Sign-In failing

Incident Report for Evolve IP EU

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 10:01 CET

Monitoring

The vendor has completed remediation activities, and services should be restored. Please retry signing in. If you continue to experience issues, please contact Client Support.
Posted Dec 01, 2025 - 09:43 CET

Investigating

Our vendor is currently investigating an issue impacting Webex sign-in. Users are experiencing login failures. The issue is being addressed with high priority, and updates will be provided as soon as more information becomes available.
Posted Dec 01, 2025 - 09:31 CET
This incident affected: Online Business Telephony (OBT - Webex).